Picture

Samuel's Website

Empêcher la MAJ du logiciel Arduino sous #!CB

Samuel Forestier — 20 May 2013
Si vous installez la version Française du logiciel Arduino (1.0.5 actuellement) sous CrunchBang, lors du prochain:
#    apt-get upgrade
... le logiciel se mettra à jour automatiquement en version 0018, ce qui est un poil embêtant, surtout pour ceux qui veulent inclure Arduino à Sublime Text.
Vous pouvez empêcher cette MAJ en vous rendant sur le Gestionnaire de paquets Synaptic.
Cherchez le paquet grâce à la barre de recherche et du mot-clé :
arduino
Sélectionnez le paquet arduino, et cliquez sur :
Paquet > Forcer la Version...
... et choisissez la version actuelle (soit 1.0.5 en ce moment).
Sélectionnez maintenant les deux paquets existants (arduino + arduino-core), et cliquez sur :
Paquet > Bloquer la version

EDIT:

Le problème n'est en fait pas complètement réglé.
Je l'ai résolu en bloquant la MAJ par ailleurs aussi.
Il suffit d'ouvrir un terminal en mode Root et de taper:
#    echo arduino hold | dpkg --set-selections

Vous pouvez checker la liste des paquets bloqués à l'aide de :
$    dpkg --get-selections | grep hold

Vous pouvez maintenant lancer un :
#    apt-get upgrade && apt-get dist-upgrade
... et vous n'aurez uniquement les MAJ de quelques librairies pour Arduino, qui n'influent en rien sur la version du logiciel (1.0.5 sera conservée).